WebMO enterprise v17 on osx 11

Post Reply
rbadger
Posts: 6
Joined: Mon Jun 22, 2020 6:46 pm
Full Name: Robert Badger
Organization: University of Wisconsin-Stevens Point
Subdiscipline: Chemistry

WebMO enterprise v17 on osx 11

Post by rbadger »

As the subject line suggests, I am trying to install WebMO enterprise server on our department server that has recently been upgraded to OS X 11 when the server stopped responding. I tried wiping out the previous install completely and starting with the original downloaded tar. The install goes fine until I try to login and then I get an error on line 13 of the login.cgi. This line contains: use ParsedHTML; and the error message suggests that ParsedHTML is not installed.

I requested a demo license for version 20, downloaded it, installed it and was able to logon as admin and set up the demo server. It turns out that the login.cgi file has the same text, but runs just fine. Hopefully, you folks can tell me how I can get our enterprise version running again. Thank you in advance, Robert Badger.

schmidt
Posts: 50
Joined: Sat May 30, 2020 3:00 pm
Full Name: JR Schmidt
Organization: WebMO, LLC

Re: WebMO enterprise v17 on osx 11

Post by schmidt »

Can you please clarify? Are you saying that v17 Enterprise exhibits the problem, but v20 (of WebMO basic) works ON THE SAME SERVER?

If so, this may be due to changes in Perl a few year ago (due to security changes) that broke compatibility with older versions of WebMO. These were addressed in WebMO 18 and higher, which may explain what is going on.

rbadger
Posts: 6
Joined: Mon Jun 22, 2020 6:46 pm
Full Name: Robert Badger
Organization: University of Wisconsin-Stevens Point
Subdiscipline: Chemistry

Re: WebMO enterprise v17 on osx 11

Post by rbadger »

Thank you for the response. I wish we could afford to upgrade, but alas higher education gets poorer with each passing year.

Robert Badger

rbadger
Posts: 6
Joined: Mon Jun 22, 2020 6:46 pm
Full Name: Robert Badger
Organization: University of Wisconsin-Stevens Point
Subdiscipline: Chemistry

Re: WebMO enterprise v17 on osx 11

Post by rbadger »

Is there any way I can patch version 17 so it will run properly under Big Sur (MacOS 11) or greater?

Thanks, Robert Badger.

Post Reply