Error after installing Psi4 and enabling on the computational engine.

Post Reply
upendart
Posts: 2
Joined: Thu Sep 02, 2021 2:03 pm
Full Name: Upendar T
Organization: Fordham

Error after installing Psi4 and enabling on the computational engine.

Post by upendart »

Hello,

I installed the WebMo Enterprise version 21 and Psi4 engine (https://www.webmo.net/support/binaries_linux.html#psi4) in the Cloud (Azure).
I enabled the Psi4 configured path using the Interface manager under admin.
I am trying to run the test job using Psi4 and getting the below error.

Traceback (most recent call last):
File "/usr/local/miniconda/bin/psi4", line 137, in <module>
raise KeyError(f"Too many unknown arguments: {unknown}")
KeyError: "Too many unknown arguments: ['-p', '28', 'input.inp', 'output.out']"

Can you please take a look and assist us with the solution to fix it?

FYI, I am using the latest WebMo licensed version.

Thanks,
Upendar

webmo
Site Admin
Posts: 11
Joined: Sun Apr 05, 2020 7:16 pm
Full Name: WebMO Forum Administrator
Organization: WebMO LLC

Re: Error after installing Psi4 and enabling on the computational engine.

Post by webmo »

This is a known issue. A patch will be released later this week to address this. In the meantime, simply removing the offending "-p" option in run_psi.cgi will fix it.

upendart
Posts: 2
Joined: Thu Sep 02, 2021 2:03 pm
Full Name: Upendar T
Organization: Fordham

Re: Error after installing Psi4 and enabling on the computational engine.

Post by upendart »

As mentioned, I removed the "-p" option in run_psi.cgi, still it shows the same error.

Please see the below error after removing "-p"

Traceback (most recent call last):
File "/usr/local/miniconda/bin/psi4", line 137, in <module>
raise KeyError(f"Too many unknown arguments: {unknown}")
KeyError: "Too many unknown arguments: ['29', 'input.inp', 'output.out']"

Post Reply